Title Back Colour Keyoti Title Line Title Curve
Blue Box Top

Increase in textbox size slows spellcheck performance - RapidSpell Desktop .NET - Forum

Welcome Guest Search | Active Topics | Log In | Register

Options
EasternHealth
#1 Posted : Thursday, November 22, 2018 1:20:25 PM
Rank: Newbie

Groups: Registered

Joined: 11/22/2018
Posts: 2
I use RapidSpell Desktop v5 in a C# Winforms application. I have noticed that the text entry performance decreases as the size (area) of the textbox increases. The larger the textbox (width or height) the greater the lag, regardless of how much text is in the box.

When the textbox fills the screen the text lags by several seconds. When the textbox is small, there is no lag.

Is there something I can do to resolve this?
Jim
#2 Posted : Friday, November 23, 2018 8:38:53 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,566
Location: Canada
If you have a large textbox full of errors, I could see that getting quite slow. Every underline contributes to the workload, so if you are checking jibberish then it is going to slow down.

With a full screen RichTextBox filled with text that has about 20 errors, it is slower on my machine, but the lag is less than a second per key stroke.

Is there anything that you can do about it?

You could try setting RapidSpellAsYouType.SetRepaintTimer(500); this will make it so that the underlines are only painted after the user pauses for 500ms.

Jim

-your feedback is helpful to other users, thank you!

Google+
EasternHealth
#3 Posted : Wednesday, November 28, 2018 3:09:33 PM
Rank: Newbie

Groups: Registered

Joined: 11/22/2018
Posts: 2
Thanks for the reply Jim. As I stated in the original post, the amount of text does not seem to matter. Your suggestion did correct the performance issue, however, for some reason the red underlining does not resume if I end a word with an alphanumeric character. The previously underlined text will remain underlined but the text entered since then will not be until I end with a non-alphanumeric character, such as a space or a period.

I had developed a workaround by temporarily removing the textbox from the Rapid Spell instance and adding it after 500 ms of inactivity. This approach did not suffer from the strange bug described above.

Thanks again.
Jim
#4 Posted : Wednesday, November 28, 2018 7:07:01 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,566
Location: Canada
Yes, you did say about the amount of text but I meant the amount of errors, difference being every underline demands position calculations...

Anyway, there is a user property (in options, through the dialog control) for ignoring words with digits, it could be related to that. I will have to check it out.
-your feedback is helpful to other users, thank you!

Google+
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.




About | Contact | Site Map | Privacy Policy

Copyright © 2002- Keyoti Inc.