Title Back Colour Keyoti Title Line Title Curve
Blue Box Top

MSG - SearchUnit - Forum

Welcome Guest Search | Active Topics | Log In | Register

2 Pages 12>
Options
mikegraz
#1 Posted : Tuesday, January 7, 2020 8:41:30 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
I have added MSG files to Keyoti SearchUnit and after in import the files show as indexed but the contents of the MSG do not appear to be indexed. Meaning that no MSG files appear when I try to filter the files. None of the content of the MSG files are searchable. What I'm I doing wrong? Other files type are working fine.

Don't know if this helps but when looking at the column description in the Index Management Tool the description for the MSGs only have the name of the file while the other files types appear to show the content of the file
Jim
#2 Posted : Wednesday, January 8, 2020 7:25:02 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,606
Location: Canada
Hi, SearchUnit uses a Windows IFilter to read MSG files. This relies on the IFilter to be registered properly for 32bit and 64bit applications. If it is not installed for 32bit then it's not going to work.
.NET applications build by default for AnyCPU but 'prefer 32 bit'. So it looks like because SearchUnit was built like that that and you don't have an IFilter for 32 bit on your machine.

We will change to build for AnyCPU (no prefer x86) from now on, would you like a new MSI (or just the DLLs)?

Thanks
Jim
-your feedback is helpful to other users, thank you!


mikegraz
#3 Posted : Wednesday, January 8, 2020 7:31:26 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
I think the DLLs would be fine.
Jim
#4 Posted : Wednesday, January 8, 2020 7:55:28 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,606
Location: Canada
Here you are

https://www.dropbox.com/...Wno9Jy_mSEb6hmqhlxKuHN4

-your feedback is helpful to other users, thank you!


mikegraz
#5 Posted : Wednesday, January 8, 2020 10:51:32 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
Looks like I will need a new MSI. Coping the DLLs don't work
Jim
#6 Posted : Thursday, January 9, 2020 5:32:10 AM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,606
Location: Canada
I will prepare it on Thursday, but in case you didn't already, you will need to rebuild the solution with the new DLLs as references, you can't just copy them over the old ones.
-your feedback is helpful to other users, thank you!


Jim
#7 Posted : Thursday, January 9, 2020 6:22:40 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,606
Location: Canada
Here's the complete MSI https://www.dropbox.com/...JqD44uxYMjmicKmGGlIYXfN4
-your feedback is helpful to other users, thank you!


mikegraz
#8 Posted : Wednesday, January 15, 2020 3:23:53 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
I installed the new MSI and re-imported the source but the contents of the MSGs still don’t appear to be indexed. When I search for Alberta I get no results.

Jim
#9 Posted : Wednesday, January 15, 2020 7:01:00 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,606
Location: Canada
Could you try this project please

https://www.dropbox.com/...xKSGHZGstcB8IxDMj_qpfjA

It's not particularly user friendly, but when you run it you will see a textbox with the file path, set that to your test MSG please. Then click the button next to it to read the file.

It should show a message box with the file content, but it may show an exception instead. If it shows an exception then it means an MSG IFilter isn't installed on your system. Can you try going to the build option in project properties and change the architecture to x86 and then x64 and see if it makes a difference please?

-your feedback is helpful to other users, thank you!


mikegraz
#10 Posted : Wednesday, January 15, 2020 8:03:28 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
Ok. Thanks. I'll give this a try. If I don't have MSG IFilter installed. How do I installed it? Is it just a matter of installing outlook?
mikegraz
#11 Posted : Wednesday, January 15, 2020 8:24:44 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
I tried your project. The message box came up fine when I pointed it to the file (EDD0000045137.MSG, this is the test file I believe I sent to you as well.) But the message box was blank, no text. I tried changing the architecture to x86 and then x64. That did not make a difference.
Jim
#12 Posted : Wednesday, January 15, 2020 8:37:21 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,606
Location: Canada
Curious. If you're game you could install this one for example

https://www.microsoft.co...d/details.aspx?id=17062

Although not getting an error typically means that there is an ifilter handling the request.
-your feedback is helpful to other users, thank you!


mikegraz
#13 Posted : Wednesday, January 15, 2020 8:47:12 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
Ok. I'll try it tomorrow and let you know. Thanks.
mikegraz
#14 Posted : Thursday, January 16, 2020 4:51:08 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
Know i'm getting text but I don't see the body in the email i'm testing with.
I should see the text 'Attached is a draft letter to Alberta Darling. Let me know your thoughts. (Not those thoughts, Tim).'

This is the text I get:

PM.NoteDraft LetterJ....
Jim
#15 Posted : Thursday, January 16, 2020 6:02:47 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,606
Location: Canada
Thanks, I took out the contents because of the email addresses etc, but I noticed that the text I am getting is the same right up until the content you are interested in

------_=_NextPart_001_01C314DA.19573EC0--
#####################Hintz, ################# LetteAttached is a draft letter to Alberta Darling. Let me know your thoughts. (Not those thoughts, Tim).


(I ##'d out names)

If you right click -> Properties on C:\Windows\System32\offfilt.dll what version do you see? Mine is

2008.0.18362.1

Did you install the x64 IFilter pack or x86?


-your feedback is helpful to other users, thank you!


Jim
#16 Posted : Thursday, January 16, 2020 6:45:13 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,606
Location: Canada
In addition, I wonder if this will help https://knowledge.autode...il-format-in-Vault.html

It mentions Windows Search, and although SearchUnit doesn't use Windows Search or it's indexer, I wonder if step 3 is a way to get to the IFilter options. See attached image

Jim attached the following image(s):
Annotation 2020-01-16 103816.png (69kb) downloaded 18 time(s).
-your feedback is helpful to other users, thank you!


mikegraz
#17 Posted : Thursday, January 16, 2020 8:52:39 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
The version of offfitl.dll is 2008.0.9600.17415

I installed the x64 IFilter pack

the windows OS i'm using is Windows Server 2012 R2

I looked at the indexing options and msg file type is there, selected, and Index Properites and File Contents is selected

I have a second computer, same OS, I have tried it there as well, same problem.
Jim
#18 Posted : Thursday, January 16, 2020 10:53:26 PM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,606
Location: Canada
According to http://www.ifiltershop.c...s/msgfilter/readme.html

"MSG IFilter requires Extended MAPI which is provided with MAPI-based applications such as Microsoft Exchange Server MAPI Client or Microsoft Outlook (ver. 98 or later). On Windows x64 platform MSG IFilter requires 64-bit edition of Microsoft Outlook 2010."

I'm unsure if they mean that the MAPI Client won't suffice for x64, but if it is OK you can get it here

https://www.microsoft.co...ad/details.aspx?id=42040
-your feedback is helpful to other users, thank you!


mikegraz
#19 Posted : Tuesday, January 21, 2020 4:00:50 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
Thanks. I'll try it tomorrow. Sorry I don't respond sooner. I've been busy the last few days.
mikegraz
#20 Posted : Wednesday, January 22, 2020 7:37:55 PM
Rank: Member

Groups: Registered

Joined: 1/25/2019
Posts: 15
I installed Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1 and nothing changed. I also try your code on my windows 10 computer. Same result, there is text in the message box but no body text.
2 Pages 12>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.




About | Contact | Site Map | Privacy Policy

Copyright © 2002- Keyoti Inc.