Title Back Colour Keyoti Title Line Title Curve
Blue Box Top

modal javascript dialog getting 413 error on server running SSL - RapidSpell Web ASP.NET - Forum

Welcome Guest Search | Active Topics | Log In | Register

Options
RobinH
#1 Posted : Wednesday, January 19, 2022 11:28:41 PM
Rank: Newbie

Groups: Registered

Joined: 1/12/2022
Posts: 2
Location: Albany, OR
I have my website set up to run with the dialog based implementation of version 6 with the jQuery UI in modal mode. I am not using the AYT implementation.

Everything seems to be working with the application in the development environment. When I created a build and put it up on our testing server, everything seems to work except one form that has a lot of text area controls on it. When I attempt to run the spell check dialog, I get a 413 error from the server. From doing some research, this appears to be an issue with the request size being too large. I've so far been unable to determine how to resolve this but I was wondering if yo have seen this before.

I'm playing with server settings to try and get the app changed. The server is running SSL where I am not in my development environment. From reading about 413 errors, it seems like SSL is a factor.

The form having issues has 15 text fields on it. We have a few forms with many text fields like that. In reading about fixes for this issue, they suggest changing the default uploadReadAheadSize value but there are a number of people who comment about there being downsides to doing this. We have a number of users in our user base who have slow connections and I don't want to do anything that causes more issues for those users.

Let me know if you have any suggestions. I will continue to experiment with settings.
Jim
#2 Posted : Friday, January 21, 2022 12:54:37 AM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 8/13/2004
Posts: 2,639
Location: Canada
If you're not seeing the same error when the form is submitted the issue is likely specific to WCF. The spell checker calls a WCF web service.

With that in mind hopefully this is the solution https://stackoverflow.co...or-413-entity-too-large

-your feedback is helpful to other users, thank you!


Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.




About | Contact | Site Map | Privacy Policy

Copyright © 2002- Keyoti Inc.